Troubleshooting on-prem clients installation
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This functionality is currently in limited availability. If you’re interested in trying it out, get in touch with us through servicedesk@celonis.com.
We've gathered some resources and troubleshooting tips that will help you resolve your problems with on-prem clients installation. For additional help, see also Troubleshooting.
Symptoms
When trying to open the opc-management-tool.app on MacOS, the following error is displayed:
"opc-management-tool.app" is damaged and can't be opened. You should move it to the Bin.
Cause
The most common root cause of this issue is missing privileges.
Solution
To resolve this problem:
Go to the Shared folder.
Open Terminal and issue the following command:
xattr -cr opc-management-tool.app
Symptoms
In the On-prem Client Management Tool, when you click Connect to EMS to request code authorization the following error is displayed:
Error: request for device code authorisation returned status 403 (Forbidden).
Cause
The error usually occurs when a VPN is required for connecting.
Solution
Enable your VPN and try again.
Symptoms:
The On-prem Client Management Tool returns the following error during the installation:
Microsoft Edge can't read and write to it's data directory. C:\Users{admin-account}\AppData\Roaming{wails-app-name}.exe\EBWebView"
Cause:
This error can occur when the opc-management-tool.exe is run using a non-admin account.
Solution:
Using a non-admin user account:
Open Task Manager.
In the Details tab, search for
msedgewebview2
Right-click any of the msedgewebview2.exe executables and go to its properties.
In the Compatibility tab, select Run this program as an administrator.
Click OK.
Open the opc-management-tool.exe again.